Secret Server Cloud: SEA - Degraded Performance

Incident Report for Delinea

Postmortem

Incident Overview 

On July 29, 2026, a subset of Secret Server Cloud customers in the Singapore region experienced a performance issue due to increased load on backend infrastructure. Affected users experienced slow response times or difficulty accessing their instance. 

Start of Impact: July 29, 1:41AM UTC 

End of Impact: July 29, 2:32AM UTC 

Root Cause 

During the affected period, a shared backend resource supporting the Singapore region experienced a spike in utilization that pushed it to its maximum capacity. An automated process responsible for scaling resources to handle the increased load failed to execute as expected, resulting in increased response times for a subset of customers in that region. 

Preventative Actions 

To prevent recurrence, the following measures are being implemented: 

  • Enhancing our automated scaling process to reduce the risk of similar issues occurring in the future. 

We sincerely apologize for the disruption this caused and the inconvenience to your operations. We are committed to preventing recurrence through the above actions.

Posted Aug 20, 2026 - 07:51 EDT

Resolved

We identified an issue affecting Secret Server Cloud for a subset of customers in the Singapore region due to increased load on backend infrastructure. Affected users experienced slow response times or difficulty accessing their instance. This was a performance issue only. This issue has been resolved and normal performance has been restored. We apologize for any inconvenience this may have caused.

Backfill Notice: This incident was added to our status page retrospectively to provide an accurate record of service impact. More information on backfill incidents is available here.
Posted Jul 28, 2026 - 21:41 EDT