Platform: Login Failures and Degraded Performance

Incident Report for Delinea

Postmortem

Incident Overview

On August 28, 2026, Delinea Platform customers in the US region experienced intermittent login failures and slow performance when signing in or accessing their tenants, including error or timeout pages on the sign-in screen for some users. In some cases, retrying the login attempt allowed users to successfully access their tenant.  

  • Start: August 28, 2026 approximately 17:29 UTC 
  • End: August 28, 2026 approximately 19:19 UTC 

Root Cause and Remediation 

A caching related code change that was made on Aug 27, combined with an unusually large volume of background synchronization activity on Aug 28, exceeded the normal operating capacity of our caching infrastructure supporting login and authentication services. Connections to it began failing and other dependent services attempted to recover those connections repeatedly rather than cleanly, preventing the caching infrastructure from stabilizing on its own. This led to slow or failed login attempts and delays in identity-related operations across the US region. 

Our engineering team rolled back the caching change and restarted the affected services, which cleared the failed connections and began restoring functionality, though performance remained degraded. The caching resource was scaled up to restore normal performance. We continued to closely monitor the service until full recovery was confirmed. 

Preventative Actions

  • Increase the capacity and resiliency of our caching infrastructure by distributing workloads across additional resources. 
  • Correct monitoring thresholds to ensure capacity pressure is detected proactively before it impacts platform performance.  
  • Limit connection-recovery retries to prevent recovering connections from compounding system load during a stress event. 
  • Apply rate limiting to large synchronization jobs to prevent any single job from negatively impacting platform-wide performance. 

We sincerely apologize for the disruption this caused and the inconvenience to your operations. We are committed to preventing recurrence through the above actions.

Posted Sep 09, 2026 - 21:00 EDT

Resolved

This incident has been resolved. Login and access to the Delinea Platform in the US region have returned to normal, and users should no longer encounter errors or degraded performance when signing in. We are continuing our investigation into the underlying cause and will share a root cause analysis once that investigation is complete. We apologize for the disruption this caused.
Posted Aug 28, 2026 - 16:16 EDT

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Aug 28, 2026 - 15:33 EDT

Identified

The issue has been identified and a fix is being implemented.
Posted Aug 28, 2026 - 15:19 EDT

Update

We are continuing to investigate login and access issues affecting the Delinea Platform in the US region. Affected users may see an "upstream request timeout" error message when attempting to sign in, or may experience slow performance when accessing their tenant. Our engineering team is fully engaged and treating this as a top priority. We will provide an update as soon as more information is available.
Posted Aug 28, 2026 - 14:27 EDT

Investigating

We are investigating an issue affecting login and access to the Delinea Platform in the US region. Some users may be unable to log in or may experience slow performance when accessing their tenants. In most cases, retrying the login attempt allows users to successfully access their tenant. Our engineering team is actively engaged. We will provide an update as soon as more information is available.
Posted Aug 28, 2026 - 14:02 EDT
This incident affected: US (Platform).