Secret Server: Login and Access issues

Incident Report for Delinea

Resolved

This incident has been resolved.
Posted Sep 22, 2026 - 09:07 EDT

Monitoring

We are continuing to monitor for any further issues
Posted Sep 22, 2026 - 08:58 EDT

Investigating

We are investigating an issue affecting login and access to Secret Server Cloud for a subset of customers across the US, EU, and UAE regions. Our engineering team is actively investigating the issue and working to resolve it as quickly as possible.
Posted Sep 22, 2026 - 08:11 EDT
This incident affected: US (Secret Server Cloud), EU (Secret Server Cloud), and UAE (Secret Server Cloud).