Secret Server Cloud: UK - Access Denied when accessing SSC

Incident Report for Delinea

Postmortem

Incident Overview 

On Monday, March 16, 2026, customers hosted on the Delinea Secret Server Cloud (SSC) UK cluster experienced a service disruption that prevented access to the SecretServer endpoint. The Delinea WAF blocked inbound traffic to the affected endpoint as an automated protective response after regional traffic volumes exceeded predefined DDoS threshold limits. 

  • Start Time: February 16, 2026 – 10:03 UTC 

  • End Time: February 16, 2026 – 10:57 UTC 

Root Cause 

The incident was caused by abnormally high traffic generated by a single customer Secret Server engine, which exceeded predefined DDoS protection threshold limits in the UK region. 

Key contributing factor: 

  • Engine request spike: Traffic from secret-server-engines increased dramatically from a typical baseline of fewer than 100 calls to approximately 27,000 calls, triggering automated DDoS protection mechanisms. 

Preventive Actions 

  • The UK site DDoS threshold was temporarily increased to 4500, allowing legitimate but abnormal traffic patterns to be handled while ensuring continued regional protection. 

  • Enhance monitoring to identify sharp, customer-specific engine call spikes.

Posted Mar 26, 2026 - 01:26 EDT

Resolved

We are investigating reports from a subset of customers experiencing "Access Denied" errors, intermittent blocking, or unexpected captcha challenges when accessing Secret Server Cloud. Our cloud Web Application Firewall (WAF) provider detected an anomalously high request rate and activated DDoS mitigation, which resulted in these access issues.

Upon investigation, we verified that the increased request count was legitimate and worked with our WAF provider to disable mitigation for this event. We will continue to collaborate with our vendor to improve anomaly detection and reduce the likelihood of false-positive events in the future.

We apologize for any inconvenience this may have caused and appreciate your patience as we work to ensure reliable access.
For assistance or further updates, please contact our support team at https://support.delinea.com.
Posted Mar 16, 2026 - 06:00 EDT