Platform: US - intermittent login failures
Incident Report for Delinea
Postmortem

Impact

A subset of Platform customers within the US data boundary could not login to their tenant intermittently.

Start of Impact (UTC): Nov 01, 2024, 03:50 PM

End of Impact (UTC): Nov 01, 2024, 06:47 PM

Incident Overview

Some platform users encountered error messages such as “HTTP failure response” and “Connection failed” which prevented access to Privileged Remote Access (PRA), Connection Manager and launching some secrets. In some cases, retrying allowed successful access.

Root cause

The latest software release led to resource contention in the Identity service. To resolve the issue, we rolled back the release to its previous state and increased the resources for the impacted services.

Preventative Actions

To prevent a recurrence of this issue, we are taking the following actions:

  • Update and improve our load testing process in lower silos to catch similar issues before release.
  • Enhance monitoring of services to identify issues early. 

We apologize for the inconvenience and appreciate your understanding as we continue to improve platform reliability.

Posted Dec 18, 2024 - 12:46 EST

Resolved
This incident has been resolved.
Posted Nov 10, 2024 - 16:12 EST
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Nov 10, 2024 - 13:31 EST
Update
We are continuing to investigate this issue and are fully focused on mitigating its impact as quickly as possible. We’ll provide the next update in one hour or sooner if there are any significant developments.
Posted Nov 10, 2024 - 11:15 EST
Investigating
We are currently investigating reports of intermittent login failures. In some cases, retrying allows successful access.
Posted Nov 10, 2024 - 10:03 EST
This incident affected: US (Platform).