Privileged Access Service / Cloud Suite Pod34 increased latency and unresponsiveness

Incident Report for Delinea

Resolved

We’re pleased to inform you that the incident affecting the service(s) listed below has been resolved. The load causing the issue has resolved.

We apologize for any inconvenience this incident may have caused, and we appreciate your understanding and support.

For any questions or concerns, please reach out to our support team at https://support.delinea.com.
Posted Apr 26, 2026 - 01:49 EDT

Investigating

We are investigating reports of degraded performance affecting Privileged Access Service / Cloud Suite Pod34. Some users may experience slower than normal response times.

Users may encounter slow page loads, increased latency, or timeouts.

Our team is actively investigating.
Posted Apr 26, 2026 - 01:19 EDT
This incident affected: US (Privileged Access Service / Cloud Suite).