Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Oct 18, 2025 - 04:00 EDT
Update
We will be undergoing scheduled maintenance during this time.
Posted Oct 17, 2025 - 15:23 EDT
Scheduled
Delinea will be upgrading Cloud Suite pods 25, 27, 29, 31, 33, 34, 36, 40, 52, and 56 to Hot Fix 6 on Saturday, October 18th from 4:00 am to 1:30 pm EDT. Potential service disruptions and latency can be expected since this is a full upgrade. This hot fix is designed to help with the issues customers have seen with lag time in their environments.
Please note, this is only for the pods mentioned above. All other pods will be completed next week.
Thank you for your patience while this maintenance is performed. If you have any questions or experience any issues, please open a case at https://support.delinea.com or call our support line at +1 202-991-0540.
Posted Oct 10, 2025 - 13:57 EDT
This scheduled maintenance affected: US (Privileged Access Service / Cloud Suite), UK (Privileged Access Service / Cloud Suite), EU (Privileged Access Service / Cloud Suite), CA (Privileged Access Service / Cloud Suite), and SEA (Privileged Access Service / Cloud Suite).