SSC UK - Service Bus Degradation
Incident Report for Delinea
Postmortem

Title: Some customer Service Bus Namespaces in the UK experienced timeouts and failures.

Impact:

At 11:42 UTC on 05/08/2024 customers may have experienced periodic errors in some Secret Server Cloud UK operations that relied on background processing. Distributed Engines may have also had errors connecting or retrieving messages. Mitigation was started at 14:25 UTC and fully resolved by 15:00 UTC on 05/08/2024.

Issue:
The UK azure region hosting secret server cloud UK had a platform issue with service buses. This caused some customer service buses to have an increased error rate or timeout when connecting.

Resolution:
Azure rolled back their update to an underlying service that had caused the error, at which point service buses became available again.

Action Items:
To address this and prevent future occurrences:
Investigate possibilities for automatic regional failover or higher resiliency for customer service buses.

Incident Start Time: 11:42 UTC - 05/08/2024
Incident End Time: 15:00 UTC - 05/08/2024.

Posted May 16, 2024 - 11:12 EDT

Resolved
The service bus issue has been resolved by Azure and all services are operating normally.

For any questions or concerns, please reach out to our support team at https://support.delinea.com.
Posted May 08, 2024 - 11:18 EDT
Identified
We are currently monitoring a service degradation for Azure Service Bus in the UK.

Currently we are not seeing any issues affecting customers but will post updates as events warrant.

For any questions or concerns, please reach out to our support team at https://support.delinea.com.
Posted May 08, 2024 - 10:55 EDT
This incident affected: UK (Secret Server Cloud).