Secret Server Cloud: Errors when accessing secrets

Incident Report for Delinea

Postmortem

Incident Overview

On October 2, 2025, a subset of customers could not access secrets within their tenant. When they tried to access secret’s general tab, they saw an error message like "s.getTime is not a function." This impacted only active directory secrets linked to discovered accounts with a populated AD expiration date field.  Other secret types, and active directory secrets without a populated AD expiration date field were not impacted.  

Start Time: October 2, 2025, 02:30 PM EDT  

End Time: October 2, 2025, 04:55 PM EDT  

Root Cause

A bug was introduced in the latest Secret Server Cloud release. We reverted the release to restore the functionality for the impacted secrets. The issue occurred because the system misread the expiration date field on Active Directory secrets. In some cases, the system expected the field to always be stored in one format, but in reality, it could appear in different formats. When an expiration date was present, this mismatch caused the error and prevented access.

Preventive Actions

To prevent recurrence, the following actions are planned or in progress:  

Fix how the system reads and processes the expiration date field, so it works reliably in all cases.    

Update internal checks so similar mismatches in field formats are caught before release.

Posted Oct 07, 2025 - 20:21 EDT

Resolved

This incident has been resolved.
Posted Oct 01, 2025 - 17:04 EDT

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Oct 01, 2025 - 16:36 EDT

Update

We are continuing with the rollback of latest release in US region. Rollback in other regions is complete. Tenants in other regions except US are able to access the secrets that were previously showing an error

Thank you for your patience. We apologize for the inconvenience this has caused.
Posted Oct 01, 2025 - 16:13 EDT

Identified

Rollback of the latest release is in progress. We will share the next update in 30minutes or sooner.
Thank you for your patience.
Posted Oct 01, 2025 - 15:31 EDT

Investigating

We are currently investigating an issue that is impacting a subset of Secret Server Cloud customers. When accessing certain type of secrets, users are seeing a red banner with an error message - "s.getTime is not a function". We are reverting the latest deployment that is causing this issue.

We apologize for any inconvenience this may have caused.

For any questions or concerns, please reach out to our support team at https://support.delinea.com.
Posted Oct 01, 2025 - 15:13 EDT
This incident affected: US (Secret Server Cloud), UK (Secret Server Cloud), EU (Secret Server Cloud), SEA (Secret Server Cloud), AU (Secret Server Cloud), CA (Secret Server Cloud), and UAE (Secret Server Cloud).