Secret Server Cloud: Remote Password Changing (RPC) Performance Issues

Incident Report for Delinea

Resolved

The incident was resolved for the US region by 2025-03-30 at 08:52 AM ET.
The incident was resolved for the EU region by 2025-03-31 at 05:42 AM ET.
Posted Mar 31, 2025 - 05:42 EDT

Monitoring

The rollback of the latest release is complete. We are now monitoring system performance to ensure stability. Users should see improvements, but we will continue to observe and validate the resolution.

We will provide a final update once the issue is fully confirmed as resolved. Thank you for your patience.
Posted Mar 30, 2025 - 08:32 EDT

Identified

We are investigating an issue affecting the Remote Password Changing (RPC) feature on Secret Server Cloud, where users may experience slow updates or intermittent failures. To mitigate the impact, we are rolling back the latest release.

We will provide further updates as we monitor the rollback and confirm service stability. Thank you for your patience.
Posted Mar 30, 2025 - 08:23 EDT

Investigating

We are currently investigating an issue affecting the Remote Password Changing (RPC) feature on Secret Server Cloud. Users may experience slow updates or intermittent failures when performing password changes. Our team is actively analyzing the latest release to identify the root cause and will provide updates as we learn more.

Thank you for your patience.
Posted Mar 30, 2025 - 07:57 EDT
This incident affected: US (Secret Server Cloud) and EU (Secret Server Cloud).