Platform: AU - PRA Connector registration failures

Incident Report for Delinea

Postmortem

Incident Overview 

On June 23, 2025, a subset of customers in the Australia region experienced failures when attempting to register PRA connectors. Affected users encountered various error messages, including: 

  • “An expected error has occurred, please try again. Http failure response with 500 OK” 

  • “Error during Engine Management registration. No client credentials found for service account” 

  • “Command execution failed because the underlying process (delinea-clientmgr.exe#7284) returned a non-zero exit code (1)” 

Start of Impact (UTC): June 23, 02:51 AM UTC 

End of Impact (UTC): June 23, 08:21 AM UTC 

The impact was limited to connector registration operations; existing connector functionality was not disrupted. 

Root cause 

The incident was triggered by an inconsistency in engine connection status tracking within the platform database. Specifically, when an engine disconnected due to a transient network issue, the database update query to mark its status as “Offline” failed. As a result, the platform continued to treat the engine as “Online.” When the engine attempted to reconnect, the system rejected the request based on the incorrect assumption that it was already connected. 

Restarting relevant services forced the system to re-evaluate engine statuses, marking them as "Offline" and allowing reconnections to proceed successfully. 

 Preventative Actions 

  • We are working to address the underlying issue and ensure engine statuses are reliably updated in the database, even in cases of network disruption. 

  • Plans are in place to introduce additional monitoring for engine state inconsistencies.

Posted Jun 24, 2025 - 22:48 EDT

Resolved

We are currently experiencing a service disruption in AU region. A subset of Platform customers are experiencing issues when registering PRA Connectors.

Affected users encountered error messages during connector registration. The issue has since been resolved and normal functionality has been restored.

We apologize for any inconvenience this has caused.

For any questions or concerns, please reach out to our support team at https://support.delinea.com.
Posted Jun 22, 2025 - 23:00 EDT