All Regions - Secret Launching Errors on Secret Server Cloud and Platform

Incident Report for Delinea

Postmortem

Incident Overview 

On July 11, 2026, following a Secret Server Cloud release, customers using Session Connector launchers experienced secret launch failures, including launches brokered through the Delinea Platform. Affected launches returned an HTTP 500 error and no connection file was generated. Other launcher types and all other Secret Server functionality were unaffected. 

  • Start: July 11, 2026, approximately 5:00 PM UTC
  • End: July 12, 2026, 8:34 AM UTC (rollback completed across all regions)

Root Cause and Remediation

The release changed how launcher configuration is resolved at launch time in a way that was incompatible with certain existing Session Connector launcher configurations. Launch requests for those configurations failed with a server error instead of completing normally. 

To remediate, our team rolled back the release across all regions. The rollback began at 8:21 AM UTC and was completed by 8:34 AM UTC on July 12, resolving the incident. Following the rollback, our team confirmed with affected customers that secret launching had returned to normal function. No action was required from customers. 

A corrected fix has been completed and verified with expanded automated regression coverage for Session Connector to launch configurations and will be included in an upcoming Secret Server Cloud release. No customer action will be required. 

Preventative Actions

  • Automated launch test coverage is being expanded to all supported launcher types and configurations. 
  • Automated detection of new error signatures introduced by deployments, reducing time to detection and rollback for similar issues. 

We sincerely apologize for the disruption this caused and the inconvenience to your operations. We are committed to preventing recurrence through the above actions.

Posted Jul 15, 2026 - 12:07 EDT

Resolved

This incident has been resolved.
Posted Jul 12, 2026 - 07:19 EDT

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Jul 12, 2026 - 05:40 EDT

Identified

The issue has been identified and a fix is being implemented.
Posted Jul 12, 2026 - 04:38 EDT

Investigating

We are aware of an issue affecting the Delinea Platform and Secret Server Cloud where users may be unable to launch secrets, encountering the error "An error has occurred in Secret Server Cloud." Our team is actively investigating the root cause and will provide an update as more information becomes available.
Posted Jul 12, 2026 - 03:04 EDT
This incident affected: US (Secret Server Cloud), UK (Secret Server Cloud), EU (Secret Server Cloud), SEA (Secret Server Cloud), AU (Secret Server Cloud), CA (Secret Server Cloud), and UAE (Secret Server Cloud).