Secret Server Cloud: Access Issues and Errors When Navigating Between Pages

Incident Report for Delinea

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Jul 28, 2026 - 12:34 EDT

Identified

We have identified the root cause of the issue. A configuration change prevented affected tenants from connecting to the database, causing the application to fail to load and display error pages. Our engineering team has applied a corrective change and is validating the fix. We will provide another update soon.
Posted Jul 28, 2026 - 10:15 EDT

Investigating

We are investigating reports that some Secret Server Cloud users are unable to sign in and are being redirected to an error page. We are actively working to resolve the issue and will provide another update soon.
Posted Jul 28, 2026 - 10:03 EDT
This incident affects: US (Secret Server Cloud) and AU (Secret Server Cloud).