Platform: Error Message When Navigating Between Pages

Incident Report for Delinea

Postmortem

Incident Overview 

Between 2:20 PM and 3:34 PM EST on February 9, 2026, Platform users experienced red banner errors, “Cannot access ‘t’ before initialization”, when clicking on the Discovery link in the left-hand navigation. These errors occurred due to client-side bundle incompatibility introduced during a recent Platform update. 

  • Start of Impact: February 9, 2026, at 19:20 UTC  

  • End of Impact: February 9, 2026, at 20:34 UTC  

Resolution 

We resolved the incident by pinning our build tooling back to the previous compatible version of webpack, which restored correct bundle generation and eliminated the errors. Normal service was confirmed to be restored by 3:34 PM EST. 

Root cause  

The incident was caused by a minor Angular framework update that indirectly upgraded the webpack to a newer version - a change that was not explicitly requested or anticipated. This newer version of webpack generated application bundles in a format that was incompatible with our existing module federation setup, which is the mechanism we use to load different sections of the platform as separate, independently deployable units. When the incompatible bundle was loaded, it caused client-side errors that surfaced to users as red banner messages. 

Preventative Actions 

We are taking the following steps to reduce the risk of similar incidents occurring in the future: 

  • As a longer-term improvement, we are planning a migration away from our current module federation setup to native federation, which will eliminate the dependency on webpack and reduce the risk of similar issues in the future.
Posted Feb 19, 2026 - 09:41 EST

Resolved

This incident has been resolved.
Posted Feb 09, 2026 - 16:12 EST

Update

We are continuing to monitor for any further issues.
Posted Feb 09, 2026 - 15:46 EST

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Feb 09, 2026 - 15:42 EST

Identified

We are currently investigating an issue where some platform users are receiving the error message:

"Cannot access 't' before initialization"

This occurs when navigating between the following sections:

User Management
Network

At this time, we are not aware of any functional impact beyond the display of this error message.

We have identified the issue as being related to a recent release and are actively rolling back the change to restore normal behavior.

We will provide an update once the rollback is complete.
Posted Feb 09, 2026 - 15:31 EST
This incident affected: UK (Platform), US (Platform), EU (Platform), SEA (Platform), AU (Platform), CA (Platform), and UAE (Platform).