Platform: US - Customers are unable to login and getting error 504

Incident Report for Delinea

Postmortem

Incident Overview 

A subset of users in the US region experienced timeouts (Error 504s) and were unable to access their Delinea Platform tenants due to an increase in latency of a critical service.

1st Impact 

Start of Impact: September 23, 2025, at 6:29 AM (UTC) 

End of Impact: September 23, 2025, at 8:01 AM (UTC)

2nd Impact 

Start of Impact: September 25, 2025, at 9:14 AM (UTC) 

End of Impact: September 25, 2025, at 9:35 AM (UTC)

Root Cause

Infrastructure system upgrade caused resource health degradation causing an increase in latency on our critical services.

Resolution 

To prevent similar issues in the future, we are implementing the following measures: 

  • Continue engagement with our Cloud hosting provider to address the root cause of health degradation. 

  • Identify deployment configuration improvements to improve service availability.

Posted Oct 02, 2025 - 05:04 EDT

Resolved

We are currently experiencing a service disruption affecting the federation page. A subset of Platform customers are encountering 504 gateway timeout errors and are unable to log in using Single Sign-On (SSO).

We identified a resource health degradation with our cloud hosting provider. During this period, we observed a significant increase in server-side latency for the identity services.

We apologize for any inconvenience this may have caused.

We are actively working with our hosting provider to obtain further details on the issue. The issue has since been resolved, and normal functionality has been restored.

For any questions or concerns, please reach out to our support team at https://support.delinea.com.
Posted Sep 23, 2025 - 02:29 EDT