We are continuing to monitor for any further issues. We are not seeing any Application errors since 15:31PM Eastern.
Posted Apr 24, 2026 - 19:06 EDT
Monitoring
After further investigation, we determined that a failover to our secondary region was not required. We have moved the affected resources to a different availability zone within the primary region and are observing improvement in service health. Application errors are no longer being reported.
We will continue to monitor the environment closely and post a further update once the incident is fully resolved.
We apologize for the disruption and thank you for your patience.
Posted Apr 24, 2026 - 15:06 EDT
Identified
We have identified the cause of the current issues impacting Secret Server Cloud in the US region. An ongoing cloud provider incident is affecting an availability zone hosting workloads in our US East region.
Customers may encounter HTTP 500 errors when accessing the Secret Server UI, with messages similar to the following: