Secret Server Cloud & Platform - US region Service Disruption

Incident Report for Delinea

Resolved

This incident has been resolved.
Posted May 14, 2025 - 13:49 EDT

Monitoring

A fix has been implemented by our network partner and we are closely monitoring the results. Thank you for your patience.
Posted May 14, 2025 - 13:08 EDT

Identified

We identified that the connectivity issue is due to a failure of one our upstream Point of Presence (POP) location with our network partner. We are working with them to restore connectivity.
Posted May 14, 2025 - 13:07 EDT

Update

We are currently facing connectivity issues that are impacting Platform and Secret Server Cloud tenants located in the US region. However, users may still be able to log in directly.
Posted May 14, 2025 - 13:03 EDT

Update

We are continuing to investigate this issue.
Posted May 14, 2025 - 12:55 EDT

Update

We are continuing to investigate this issue.
Posted May 14, 2025 - 12:50 EDT

Investigating

We are currently experiencing a service disruption with Secret Server Cloud in the US region. We apologize for any inconvenience this may cause and appreciate your patience as we work to restore normal service.
Posted May 14, 2025 - 12:37 EDT
This incident affected: US (Platform, Secret Server Cloud).