Privileged Access Service / Cloud Suite: Tenants on Pod34 are unavailable

Incident Report for Delinea

Resolved

This incident has been resolved.
Posted Aug 14, 2025 - 13:00 EDT

Monitoring

We applied the mitigation steps to restore the service availability and we are monitoring the results.
Posted Aug 14, 2025 - 11:52 EDT

Investigating

We are currently investigating a service disruption impacting Cloud Suite Pod34. Our engineering teams are fully engaged and working to restore normal service as quickly as possible.

We apologize for any inconvenience this may cause and appreciate your patience during this time.

For assistance or updates, please contact our support team at https://support.delinea.com.
Posted Aug 14, 2025 - 11:25 EDT
This incident affected: US (Privileged Access Service / Cloud Suite).