We have not received any additional reports since the mitigation was implemented on December 30, 2025 at 18:39 EST. A permanent fix has been implemented by our network partner, and traffic has been restored to the previously impacted Point of Presence (PoP) in the Chicago data center.
We are currently completing a Root Cause Analysis (RCA) and will share it on this status page next week.
Posted Jan 05, 2026 - 18:55 EST
Update
To mitigate the impact of the upstream PoP issue, our network partner has rerouted traffic through alternate Point of Presence (PoP) locations. As a result, Secret Server Cloud tenants in US region may resolve to a different IP address.
We apologize for any inconvenience this may cause and appreciate your patience and cooperation while we continue to monitor the situation.
Posted Dec 31, 2025 - 01:58 EST
Monitoring
A fix has been implemented by our upstream network partner. We are continuing to monitor to ensure that there is no disruption in connectivity to our services.
Posted Dec 30, 2025 - 18:39 EST
Investigating
We are investigating failures accessing Secret Server Cloud (SSC) Service Portal when connecting through the Chicago, IL data center. Customers in other US regions are not impacted. Our initial findings indicate the issue is caused by an upstream network Point of Presence (PoP) failure. We are actively working with our network vendors to remediate the problem.
Workaround: If available, customers may temporarily switch to an alternate ISP or use a VPN to change the network routing to access SSC Service Portal. We will provide further updates as more information becomes available.