Platform: Unable to Launch New PRA Sessions in Non-US Regions

Incident Report for Delinea

Postmortem

Incident Overview

A subset of customers in non-US regions were unable to launch new PRA sessions and received an "Engine unavailable" error. Existing running sessions were unaffected.

  • Start: August 14, 2026, 09:46 UTC
  • End: August 14, 2026, 10:45 UTC

Root Cause and Remediation

A new version of the PRA service was deployed to production on August 14, 2026 at 09:46 UTC. The new version did not correctly apply a required configuration value in the production environment, which prevented the service from locating the session engine for non-US regions. Affected customers were consequently unable to launch new sessions and received an "Engine unavailable" error.

Following an increase in backend error rates during post-deployment monitoring, correlated with incoming customer reports, the deployment was rolled back to the previous stable version. Rollback completed at 10:45 UTC. Resolution was verified through backend logs and by confirming that impacted customers could successfully launch new sessions.

Preventative Actions

  • Review the deployment process to determine why the configuration issue was not detected prior to production release.
  • Implement a staged rollout model so that new service versions are released to a single region and validated before wider deployment.
  • Introduce automated post-deployment health checks, including a synthetic session launch per region, that gate promotion and trigger rollback on failure.

We sincerely apologize for the disruption this caused and appreciate your patience while we worked to resolve it.

Posted Aug 19, 2026 - 18:12 EDT

Resolved

This incident has been resolved. We apologize for the disruption this caused.

Investigating
We are investigating an issue where users in non-US regions are unable to establish new remote sessions. Affected users receive an "Engine unavailable" message when launching a session. Impact is limited to customers in non-US regions. Tenants hosted in the US region are not affected.

We will provide an update as soon as we have more information.

Backfill Notice: This incident was added to our status page retrospectively to provide an accurate record of service impact. More information on backfill incidents is available here.
Posted Aug 14, 2026 - 17:46 EDT