Delinea Secret Server US

Incident Report for Delinea

Postmortem

Impact

Secret Server Cloud US customers experienced delays and failed requests between 9:37 ET and 9:45 ET. Other regions were not impacted.

Start of Impact (ET): March 18, 2025, 9:37 AM ET

End of Impact (ET): March 18, 2025, 9:45 AM ET

Incident Overview

At around 9:37 AM, some web requests and messages in the US region of Secret Server Cloud timed out or responded slowly. This behavior gradually impacted a bigger percentage of web requests up until 9:42 AM. Normal behavior was restored by 9:45 AM.

Root cause

A Redis server providing caching services to the US region became unavailable from 9:37 AM to 9:42 AM ET.
This increased the load on a backend database, maxing out the SQL workers and delaying responses.

Preventative Actions

To prevent a recurrence of this issue, we are taking the following actions:

  1. Memory caching will be implemented to protect the impacted backend database from a spike in load.
Posted Mar 18, 2025 - 18:27 EDT

Resolved

The issue affecting Secret Server Cloud tenants in the US region has been resolved. We will provide a root cause analysis on our status page within seven days.
Posted Mar 18, 2025 - 11:59 EDT

Monitoring

The issue impacting Secret Server Cloud tenants has been mitigated. We are continuing to monitor the situation and will share more details as they become available.

For any questions or concerns, please reach out to our support team at https://support.delinea.com.
Posted Mar 18, 2025 - 11:03 EDT

Investigating

We are currently experiencing an intermittent service disruption.

We’re reaching out to inform you about an ongoing incident affecting the service(s) listed below.
Our team is working to identify the root cause and implement a solution.

We apologize for any inconvenience this may cause and appreciate your patience as we work to restore normal service.

For any questions or concerns, please reach out to our support team at https://support.delinea.com.
Posted Mar 18, 2025 - 09:44 EDT
This incident affected: US (Secret Server Cloud).