Remote Application Launch Failures Across Tenants

Incident Report for Delinea

Postmortem

Impact 

During this incident, a subset of users were unable to launch Remote Applications. The impact began at 9:30 AM CST on May 1st, 2025, following a service deployment.  

  • Start of Impact (UTC): 01 May 2025 14:30  
  • End of Impact (UTC): 01 May 2025 19:30 

Root cause 

Latest deployment introduced a software bug that was incompatible with another Platform service. This caused downstream requests to fail when launching Remote Applications. The impact was limited to five tenants in the US region. The issue was resolved by rolling back to a known previous release. 

Preventative Measures 

  • Expanded QA test scenarios to include cross-service dependencies. 
  • We updated our internal runbooks on rollback process to achieve a faster mitigation of issues. 
  • A new release was deployed to lower silos and our testing has confirmed that the issue is fixed. 
  • New application-level monitor will alert us immediately if this occurs in the future.
Posted May 05, 2025 - 15:36 EDT

Resolved

This incident has been resolved.
Posted May 01, 2025 - 15:50 EDT

Monitoring

We have mitigated the issue and are currently monitoring affected tenants to confirm that Remote Application functionality has been fully restored.
Posted May 01, 2025 - 15:40 EDT

Update

We are continuing to investigate this issue.
Posted May 01, 2025 - 15:23 EDT

Investigating

We are currently investigating an issue affecting Remote Application launches across multiple tenants. Our team is actively triaging the problem and will provide updates as more information becomes available.
Posted May 01, 2025 - 15:20 EDT
This incident affected: US (Platform).