Secret Server Cloud - SSL issues
Incident Report for Delinea
Resolved
At this time full functionality has been restored for all known impacted customers.
Posted Aug 12, 2024 - 16:53 EDT
Monitoring
A fix has been implemented by our vendor Imperva to their Web Application Firewall infrastructure. The service is returning to normal operation. We apologize for the inconvenience caused due to this. We will be closely monitoring the situation. If you continue to experience connectivity issues, please reach out to our Support team at https://support.delinea.com.
Posted Aug 12, 2024 - 16:11 EDT
Identified
A subset of customers in the US, CA, and UK regions are experiencing SSL issues communicating with the website. Symptoms may include issues with login, launching, or Distributed Engine connectivity.

The issues appear to be caused by our vendor Imperva Web Application Firewall - linked Imperva incident below.

https://status.imperva.com/incidents/3gnd2xf69ptg
https://status.imperva.com/incidents/lpsg2zpzqk1s
Posted Aug 12, 2024 - 12:45 EDT
This incident affected: US (Secret Server Cloud), UK (Secret Server Cloud), and CA (Secret Server Cloud).