Privilege Manager Cloud: Canada - Unable to Access Tenants (Error 20)

Incident Report for Delinea

Resolved

The issue affecting Privilege Manager Cloud tenants in the Canada region has been resolved. We apologize for the inconvenience this may have caused. If you have any questions please contact our support team at https://support.delinea.com
Posted Jun 16, 2025 - 22:59 EDT

Update

The PMC service has been available for the past 45min without any issues. We are continuing to monitor.
Posted Jun 16, 2025 - 18:54 EDT

Update

We are still seeing intermittent failures. We are investigating and appreciate your patience. The next update will be provided as we learn more.
Posted Jun 16, 2025 - 18:14 EDT

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Jun 16, 2025 - 17:02 EDT

Identified

This issue has been identified with an upstream network vendor and we are working with them to restore the service. Thank you for your patience.
Posted Jun 16, 2025 - 16:46 EDT

Investigating

We are currently investigating a service outage affecting Privilege Manager Cloud tenants hosted in Canada. Customers attempting to access the service may encounter Error 20, which indicates a proxy failure due to a TCP connection timeout when trying to reach the web server.

Our engineering team is actively working to restore connectivity and resolve the issue as quickly as possible.

We appreciate your patience and will provide updates as we learn more.
Posted Jun 16, 2025 - 16:34 EDT
This incident affected: CA (Privilege Manager Cloud).