Platform: Global – Issue with the PCS Session Recording Collector

Incident Report for Delinea

Postmortem

Incident Overview
On July 24, 2025, from 11:07 AM to 1:20 PM Central, Platform customers worldwide experienced failures when uploading Session Recordings and Audit events from the on-premise Audit Collector.
This issue affected Privilege Control for Servers and Server Suite customers sending session data to the Delinea Platform. The session recordings and associated metadata remained cached on the endpoints throughout the incident, so no customer data was lost.

Root Cause
A recent backend update introduced changes to how session recording and audit event traffic is routed within our systems. In production, some traffic was still being directed to a legacy endpoint that did not fully support the updated communication method. As a result, uploads from affected customers were rejected until routing was corrected.

Resolution
The configuration was updated so that affected services now point directly to the correct endpoint. This restored the ability for Audit Collectors to upload session recordings and audit events to the platform.

Preventive Actions

  • Align configuration between non-production and production environments to ensure consistent behavior during testing and deployment.
  • Enhance automated testing to verify that the Audit Collector can successfully upload session recordings to the platform before releases.
Posted Aug 14, 2025 - 21:18 EDT

Resolved

This incident has been resolved.
Posted Jul 24, 2025 - 16:35 EDT

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Jul 24, 2025 - 14:32 EDT

Identified

The issue has been identified and a fix is being implemented.
Posted Jul 24, 2025 - 13:33 EDT

Investigating

Platform customers worldwide are experiencing failures in uploading Session Recordings and Audit events from the on premise Audit Collector. This affects Privilege Control for Servers and Server Suite customers sending session data to the Delinea Platform. The session recordings and associated metadata will remain cached on the endpoints so no data will be lost when service resumes. We are investigating this issue and will share the next update in an hour or as events warrant.
If you have any questions or require further assistance, please contact our support team at https://support.delinea.com.
Posted Jul 24, 2025 - 12:07 EDT
This incident affected: UK (Platform), US (Platform), EU (Platform), SEA (Platform), AU (Platform), CA (Platform), and UAE (Platform).