PRA session timeouts
Incident Report for Delinea
Postmortem

Impact

Platform customers had their Privileged Remote Access (PRA) sessions end due to an error with session recording

Start of Impact (UTC): Oct 12, 2024, 11:00 AM

End of Impact (UTC): Oct 13, 2024, 01:41 PM

Incident Overview

Some platform users experienced their Privileged Remote Access (PRA) sessions ending unexpectedly with the error: "Session ended: The session has ended as session recording has unexpectedly terminated." Restarting the session would result in it ending again after a few seconds. As a temporary fix, turning off the session recording on the secret allowed users to continue their PRA sessions.

Root cause

A bug in the latest software release caused longer, high-resolution session recordings to exceed the allowable limit. A fix has been applied to resolve this issue.

Preventative Actions

To prevent a recurrence of this issue, we are taking the following actions:

  • Update and improve our testing process to catch similar issues before release.
  • Strengthen our monitoring of session recording systems to detect problems earlier.

We apologize for the inconvenience and appreciate your understanding as we continue to improve platform reliability.

Posted Oct 24, 2024 - 00:42 EDT

Resolved
We’re pleased to inform you that the incident affecting Privileged Remote Access (PRA) has been resolved. We apologize for the inconvenience this may have caused.

If you need further help on this issue or have questions, please reach out to our support team at https://support.delinea.com
Posted Oct 14, 2024 - 14:01 EDT
Monitoring
A fix has been implemented and we are monitoring the results. Thank you for your patience while we worked on restoring the services.
Posted Oct 14, 2024 - 11:13 EDT
Investigating
We are currently investigating an issue where customers may experience session timeouts for PRA Session with the error message

Warning message: Session Ended: The session has ended as session recording has unexpectedly terminated."

Our team is working to identify the root cause and implement a solution.
We apologize for any inconvenience this may cause and appreciate your patience as we work to restore normal service.
For any questions or concerns, please reach out to our support team at https://support.delinea.com.
Posted Oct 14, 2024 - 01:01 EDT
This incident affected: UK (Platform), US (Platform), EU (Platform), SEA (Platform), AU (Platform), and CA (Platform).