Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Apr 19, 2025 - 04:30 EDT
Scheduled
Delinea will be installing security patches on all Cloud Suite pods, except pod 31, on Saturday, April 19th from 4:30 am to 2:00 pm EST. There may be some minor service disruptions during this time and all SSH and RDP connections will be reset. Thank you for your patience while this maintenance is performed. If you have any questions or experience any issues, please open a case at https://support.delinea.com or call our support line at +1 202-991-0540.
Posted Apr 10, 2025 - 16:52 EDT
This scheduled maintenance affected: BR (Privileged Access Service / Cloud Suite), US (Privileged Access Service / Cloud Suite), UK (Privileged Access Service / Cloud Suite), EU (Privileged Access Service / Cloud Suite), AU (Privileged Access Service / Cloud Suite), CA (Privileged Access Service / Cloud Suite), and SEA (Privileged Access Service / Cloud Suite).