Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Jul 12, 2025 - 04:00 EDT
Scheduled
Delinea will be upgrading Cloud Suite pod 31 and pod 35 to release 25.1 on Saturday, July 12th from 4:00 am to 1:30 pm EDT. Service disruption and latency can be expected since this is a full upgrade.
Please note, this is only for pod 31 and pod35.
Also please note. If you use Cloud Suite and Server Suite for MFA, please ensure that your Server Suite agents are at the latest versions or, if using older versions, please see the KB article for more information: https://support.delinea.com/s/article/1751053176339
Thank you for your patience while this maintenance is performed. If you have any questions or experience any issues, please open a case at https://support.delinea.com or call our support line at +1 202-991-0540.
Posted Jul 02, 2025 - 17:14 EDT
This scheduled maintenance affected: BR (Privileged Access Service / Cloud Suite), US (Privileged Access Service / Cloud Suite), UK (Privileged Access Service / Cloud Suite), EU (Privileged Access Service / Cloud Suite), AU (Privileged Access Service / Cloud Suite), CA (Privileged Access Service / Cloud Suite), and SEA (Privileged Access Service / Cloud Suite).