Privileged Access Service / Cloud Suite - Pod34 Intermittent Issue

Incident Report for Delinea

Resolved

This incident has been resolved.
Posted May 20, 2025 - 15:23 EDT

Monitoring

A fix has been implemented and we are monitoring the results.
Posted May 20, 2025 - 11:29 EDT

Investigating

We are currently experiencing a service disruption affecting Privileged Access Service tenants hosted on Pod34. Customers may encounter the following error when attempting to access the service:

"Query has failed: Storage layer exception occurred"

Our engineering team is actively investigating the issue and working to implement a fix. We apologize for the inconvenience and appreciate your patience as we work to restore normal service.

If you have any questions or concerns, please contact our support team at https://support.delinea.com
Posted May 20, 2025 - 10:32 EDT
This incident affected: US (Privileged Access Service / Cloud Suite).